Wednesday 28 December 2016

Port-Channel 002

Topo:




Configure port channels between N7K3, N7K4, N5K1, and N5K2 as follows:
The links between N5K1 and N7K3 should be grouped together in Port-Channel 1. Do not use a negotiation protocol for this channel.
The links between N7K3 and N7K4 should be grouped into Port-Channels 2 and 3. Both switches should initiate LACP negotiation for both of these channels and use LACP fast timers.
The links between N5K2 and N7K4 should grouped together into Port-Channel 4. N7K4 should initiate LACP negotiation and N5K2 should respond.
Disable all other interconnections between the switches.
Configure all of these port channels as 802.1Q trunk links.
Configure N7K4 with an LACP priority of 16384 so that it is the preferred device for managing negotiation of its port channels.
Configure all switches to use source and destination TCP/UDP ports for load balancing flows across the port channel members.
Configure N5K1's link to Server 3 and N5K2's link to Server 4 in VLAN 10.
Server 3 should use the IP address 10.0.0.1/24 and Server 4 should use the IP address 10.0.0.2/24. When complete, Server 3 and Server 4 should have IP reachability to each other.
Use the iPerf application to verify that traffic flows between Server 3 and Server 4 are being distributed among the member links of the port channels.
// Note i am using mode on instead of lacp // as virl does not support lacp //
N7K-3(config)# int e2/2-3
N7K-3(config-if-range)# channel-group 2 mode on
N7K-3(config-if-range)# no sh
N7K-3(config-if-range)# int p2
N7K-3(config-if)# switchport
N7K-3(config-if)# switchport mode trunk
N7K-3(config-if)# vlan 10
N7K-3(config-vlan)# int e3/-4
                           ^
Invalid interface format at '^' marker.
N7K-3(config-vlan)# int e2/4-5
N7K-3(config-if-range)# channel-group 3 mode on
N7K-3(config-if-range)# no sh
N7K-3(config-if-range)# int p3
N7K-3(config-if)# switchport
N7K-3(config-if)# switchport mo
mode      monitor
N7K-3(config-if)# switchport mod trun
N7K-3(config-if)#
N7K-3(config-if)# int e2/8
N7K-3(config-if)# channel-group 1 mod on
N7K-3(config-if)# no sh
N7K-3(config-if)# int p1
N7K-3(config-if)# switchport
N7K-3(config-if)# switchport mode trun
// create vlan 10 as well
!
N7K-4(config)# int e2/2-3
N7K-4(config-if-range)# no sh
N7K-4(config-if-range)# channel-group 2 mo on
N7K-4(config-if-range)# int p2
N7K-4(config-if)# switchport
N7K-4(config-if)# switchport mod tr
N7K-4(config-if)# int e2/4-5
N7K-4(config-if-range)# no sh
N7K-4(config-if-range)# channel-group 3 mode  on
N7K-4(config-if-range)# int p3
N7K-4(config-if)# switchpor
N7K-4(config-if)# switchport mo
mode      monitor
N7K-4(config-if)# switchport mod trunk
N7K-4(config-if)#
N7K-4(config-if)#
N7K-4(config-if)# int e2/6
N7K-4(config-if)# channel-group 4 mod on
N7K-4(config-if)# no sh
N7K-4(config-if)# int p4
N7K-4(config-if)# switchport
N7K-4(config-if)# switchport mod tr
N7K-4(config-if)# vlan 10

interface Ethernet2/1
  switchport
  switchport mode trunk
  channel-group 1
  no shutdown

interface Ethernet2/5
  switchport
  switchport access vlan 10
  speed 1000
  no shutdown

N5K-1# sh run int p1

!Command: show running-config interface port-channel1
!Time: Fri Feb 19 04:52:06 2016

version 7.2(0)D1(1)

interface port-channel1
  switchport
  switchport mode trunk

!
N5K-2(config)# int e2/4
N5K-2(config-if)# switchport
N5K-2(config-if)# switchport access vlan 10
N5K-2(config-if)# int e2/2
N5K-2(config-if)# channel-group 4 mode on
N5K-2(config-if)# no sh
N5K-2(config-if)# int p4
N5K-2(config-if)# switchport
N5K-2(config-if)# switchport mo
mode      monitor
N5K-2(config-if)# switchport mod trunk
N5K-2(config-if)# sh port-channel su
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
        M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
4     Po4(SU)     Eth      NONE      Eth2/2(P)

!

N5K-2# sh run int e2/2,e2/4

!Command: show running-config interface Ethernet2/2, Ethernet2/4
!Time: Fri Feb 19 04:53:05 2016

version 7.2(0)D1(1)

interface Ethernet2/2
  switchport
  switchport mode trunk
  channel-group 4
  no shutdown

interface Ethernet2/4
  switchport
  switchport access vlan 10
  speed 1000
  no shutdown

N5K-2# sh run int p4

!Command: show running-config interface port-channel4
!Time: Fri Feb 19 04:53:18 2016

version 7.2(0)D1(1)

interface port-channel4
  switchport
  switchport mode trunk

!
N7K-3# sh port-c su
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
        M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      NONE      Eth2/8(P)
2     Po2(SU)     Eth      NONE      Eth2/2(P)    Eth2/3(P)
3     Po3(SU)     Eth      NONE      Eth2/4(P)    Eth2/5(P)
!

No comments:

Post a Comment