BGP CHAPTER 10(Lab on AS-PREPEND)
21. Task:
According to Diagram:
- use private AS for client(Cust1).
- Send network 172.16.1.1 as primary to ISP1 & secondary to ISP2
- Send network 192.168.1.1 as primary to ISP2 & secondary to ISP1
- Use as-prepend for this task.
- Remove private-as while sending cust1 network to ISP's.
NOte: Look carefully the configuration of R2.
----> diag:
Solution:
Configuration on devices:
hostname R1
!
!
interface Loopback1
ip address 172.16.1.1 255.255.255.255
!
interface Loopback2
ip address 192.168.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.12.1 255.255.255.0
duplex auto
speed auto
!
router bgp 65500
no synchronization
bgp log-neighbor-changes
network 172.16.1.1 mask 255.255.255.255
network 192.168.1.1 mask 255.255.255.255
neighbor 10.1.12.2 remote-as 23
no auto-summary
!
!
end
R4(config-router)#do sh ip bgp
BGP table version is 15, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 172.16.1.1/32 10.1.34.3 0 23 i
*> 192.168.1.1/32 10.1.34.3 0 23 23 23 23 23 i
R5(config-router)#do sh ip bgp
BGP table version is 19, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 172.16.1.1/32 10.1.35.3 0 23 23 23 23 23 i
*> 192.168.1.1/32 10.1.35.3 0 23 i
21. Task:
According to Diagram:
- use private AS for client(Cust1).
- Send network 172.16.1.1 as primary to ISP1 & secondary to ISP2
- Send network 192.168.1.1 as primary to ISP2 & secondary to ISP1
- Use as-prepend for this task.
- Remove private-as while sending cust1 network to ISP's.
NOte: Look carefully the configuration of R2.
----> diag:
Solution:
Configuration on devices:
hostname R1
!
!
interface Loopback1
ip address 172.16.1.1 255.255.255.255
!
interface Loopback2
ip address 192.168.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.12.1 255.255.255.0
duplex auto
speed auto
!
router bgp 65500
no synchronization
bgp log-neighbor-changes
network 172.16.1.1 mask 255.255.255.255
network 192.168.1.1 mask 255.255.255.255
neighbor 10.1.12.2 remote-as 23
no auto-summary
!
!
end
!
hostname R2
!
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.23.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 10.1.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
passive-interface FastEthernet0/1
network 2.2.2.2 0.0.0.0 area 0
network 10.1.12.0 0.0.0.255 area 0
network 10.1.23.0 0.0.0.255 area 0
!
router bgp 23
no synchronization
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 23
neighbor 3.3.3.3 update-source Loopback1
neighbor 10.1.12.1 remote-as 65500
no auto-summary
!
end
!
hostname R3
!
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.23.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.34.3 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.35.3 255.255.255.0
clock rate 2000000
!
interface Serial0/2
no ip address
shutdown
clock rate 2000000
!
interface Serial0/3
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 10.1.23.0 0.0.0.255 area 0
!
router bgp 23
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 23
neighbor 2.2.2.2 update-source Loopback1
neighbor 10.1.34.4 remote-as 400
neighbor 10.1.34.4 remove-private-as
neighbor 10.1.34.4 route-map PREPEND out
neighbor 10.1.35.5 remote-as 500
neighbor 10.1.35.5 remove-private-as
neighbor 10.1.35.5 route-map PREPEND2 out
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
ip prefix-list M172 seq 10 permit 172.16.1.1/32
!
ip prefix-list M192 seq 10 permit 192.168.1.1/32
!
route-map PREPEND permit 10
match ip address prefix-list M172
!
route-map PREPEND permit 20
match ip address prefix-list M192
set as-path prepend 23 23 23 23
!
route-map PREPEND2 permit 10
match ip address prefix-list M192
!
route-map PREPEND2 permit 20
set as-path prepend 23 23 23 23
!
end
!
hostname R4
!
!
interface Loopback1
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.34.4 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 400
no synchronization
bgp log-neighbor-changes
neighbor 10.1.34.3 remote-as 23
no auto-summary
!
end
!
hostname R5
!
!
interface Loopback1
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.35.5 255.255.255.0
clock rate 2000000
!
router bgp 500
no synchronization
bgp log-neighbor-changes
neighbor 10.1.35.3 remote-as 23
no auto-summary
!
end
----------------------------------------------------------------
OUTPUT on ISP1 & ISP2R4(config-router)#do sh ip bgp
BGP table version is 15, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 172.16.1.1/32 10.1.34.3 0 23 i
*> 192.168.1.1/32 10.1.34.3 0 23 23 23 23 23 i
R5(config-router)#do sh ip bgp
BGP table version is 19, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 172.16.1.1/32 10.1.35.3 0 23 23 23 23 23 i
*> 192.168.1.1/32 10.1.35.3 0 23 i
No comments:
Post a Comment