Topo:
1.4 Implement NXOS L2 Functionality:
Configure L2 LACP port-channel between N7K-3 & N7K-4, also configure this
port-channel as a trunk port with jumbo MTU . Prune vlan 50,80,90 from Po100.
!
N7K-3 e2/1-2 to other side N7K-4 same interfaces:
Note if LACP is not available do it with mode on.
!
SVI and Loopback on DC-1
DC1-N7K-3 Loopback0 10.0.1.3/32
DC1-N7K-3 Vlan 30 10.1.30.124/25
DC1-N7K-3 Vlan 40 10.1.40.252/24
DC1-N7K-4 Loopback0 10.0.1.4/32
DC1-N7K-4 Vlan 30 10.1.30.125/25
DC1-N7K-4 Vlan 40 10.1.40.253/24
On DC-2 Site
DC2-N7K-3 e2/1 10.4.1.9/30
DC1-N7K-4 e2/1 10.4.1.13/30
SVI and Loopback on DC-2
DC2-N7K-3 Loopback0 10.0.2.3/32
DC2-N7K-3 Vlan 31 10.1.31.124/25
DC2-N7K-3 Vlan 41 10.1.41.252/24
DC2-N7K-4 Loopback0 10.0.2.4/32
DC2-N7K-4 Vlan 31 10.1.31.125/25
DC2-N7K-4 Vlan 41 10.1.41.253/24
Solution:
nx-osv-3(config)# int e2/1-2
nx-osv-3(config-if-range)# channel-group ?
<1-4096> Specify a port-channel number
nx-osv-3(config-if-range)# channel-group 100 mode ?
active Set channeling mode to ACTIVE
on Set channeling mode to ON
passive Set channeling mode to PASSIVE
nx-osv-3(config-if-range)# channel-group 100 mode active
LACP process needs to be started before configuring active mode
nx-osv-3(config-if-range)# channel-group 100 mode on
nx-osv-3(config-if-range)# no sh
nx-osv-3(config-if-range)# int p100
nx-osv-3(config-if)# switchport
nx-osv-3(config-if)# switchport mo
mode monitor
nx-osv-3(config-if)# switchport mod trunk
nx-osv-3(config-if)# switchport trunk allowed vlan ?
<1-4094> VLAN IDs of the allowed VLANs when this port in trunking mode
add Add VLANs to the current list
all All VLANs
except All VLANs except the following
none No VLANs
remove Remove VLANs from the current list
nx-osv-3(config-if)# switchport trunk allowed vlan except 50,80,90
nx-osv-3(config-if)# mtu 9216
nx-osv-3(config-if)# sh run int p100
!Command: show running-config interface port-channel100
!Time: Sat Feb 20 09:13:50 2016
version 7.2(0)D1(1)
interface port-channel100
switchport
switchport mode trunk
switchport trunk allowed vlan 1-49,51-79,81-89,91-4094
mtu 9216
!
nx-osv-4(config-if)# int e2/1-2
nx-osv-4(config-if-range)# channel-group 100 mode on
nx-osv-4(config-if-range)# no sh
nx-osv-4(config-if-range)# int p100
nx-osv-4(config-if)# switchport
nx-osv-4(config-if)# switchport mode trunk
nx-osv-4(config-if)# switchport trunk allowed vlan 1-49,51-79,81-89,91-4094
nx-osv-4(config-if)# mtu 9216
nx-osv-4(config-if)# end
nx-osv-4# sh pro
process processes
nx-osv-4# sh por
port-channel port-profile
nx-osv-4# sh port-c summary
Flags: D - Down P - Up in port-channel (members)
I - Individual H - Hot-standby (LACP only)
s - Suspended r - Module-removed
S - Switched R - Routed
U - Up (port-channel)
M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port- Type Protocol Member Ports
Channel
--------------------------------------------------------------------------------
100 Po100(SU) Eth NONE Eth2/1(P) Eth2/2(P)
!
nx-osv-3(config-if)# sh interface ethernet2/1 switchport
Name: Ethernet2/1
Switchport: Enabled
Switchport Monitor: Not enabled
Operational Mode: trunk
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Allowed: 1-49,51-79,81-89,91-4094
Administrative private-vlan primary host-association: none
Administrative private-vlan secondary host-association: none
Administrative private-vlan primary mapping: none
Administrative private-vlan secondary mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
!
nx-osv-3(config-if)# exit
nx-osv-3(config)# fe
feature feature-set fex
nx-osv-3(config)# fea
feature feature-set
nx-osv-3(config)# feature interface-vlan
nx-osv-3(config)# int vl 30
nx-osv-3(config-if)# ip add 10.1.30.124/25
nx-osv-3(config-if)# no sh
nx-osv-3(config-if)# int vl 40
nx-osv-3(config-if)# ip add 10.1.40.252/24
nx-osv-3(config-if)# no sh
nx-osv-3(config-if)# int l0
nx-osv-3(config-if)# ip add 10.0.1.3/32
nx-osv-3(config-if)# no sh
nx-osv-3(config-if)# sh ip int brief
IP Interface Status for VRF "default"(1)
Interface IP Address Interface Status
Vlan30 10.1.30.124 protocol-up/link-up/admin-up
Vlan40 10.1.40.252 protocol-up/link-up/admin-up
Lo0 10.0.1.3 protocol-up/link-up/admin-up
Eth2/7 10.4.1.1 protocol-up/link-up/admin-up
!
nx-osv-4(config)# feature interface-vlan
nx-osv-4(config)# int vl 30
nx-osv-4(config-if)# ip add 10.1.30.125/25
nx-osv-4(config-if)# no sh
nx-osv-4(config-if)# int vl 40
nx-osv-4(config-if)# ip add 10.1.40.253/24
nx-osv-4(config-if)# no sh
nx-osv-4(config-if)# sh ip int brief
IP Interface Status for VRF "default"(1)
Interface IP Address Interface Status
Vlan30 10.1.30.125 protocol-up/link-up/admin-up
Vlan40 10.1.40.253 protocol-up/link-up/admin-up
Lo0 10.0.1.4 protocol-up/link-up/admin-up
Eth2/7 10.4.1.5 protocol-up/link-up/admin-up
!
nx-osv-7(config-if)# exit
nx-osv-7(config)# fe
feature feature-set fex
nx-osv-7(config)# fea
feature feature-set
nx-osv-7(config)# feature interface-vlan
nx-osv-7(config)# int l0
nx-osv-7(config-if)# ip add 10.0.2.3/32
nx-osv-7(config-if)# int vl 31
nx-osv-7(config-if)# no sh
nx-osv-7(config-if)# ip add 10.1.31.124/25
nx-osv-7(config-if)# no sh
nx-osv-7(config-if)# int vl 41
nx-osv-7(config-if)# no sh
nx-osv-7(config-if)# ip add 10.1.41.252/24
nx-osv-7(config-if)# no sh
nx-osv-8(config)# feature interface-vlan
nx-osv-8(config)# int vl31
nx-osv-8(config-if)# ip add 10.1.31.125/25
nx-osv-8(config-if)# no sh
nx-osv-8(config-if)# int vl 41
nx-osv-8(config-if)# no sh
nx-osv-8(config-if)# ip add 10.1.41.253/24
nx-osv-8(config-if)# sh ip int brief
IP Interface Status for VRF "default"(1)
Interface IP Address Interface Status
Vlan31 10.1.31.125 protocol-down/link-down/admin-up
Vlan41 10.1.41.253 protocol-down/link-down/admin-up
Lo0 10.0.2.4 protocol-up/link-up/admin-up
Eth2/1 10.4.1.13 protocol-up/link-up/admin-up
No comments:
Post a Comment