BGP CHAPTER 6:(LAB-CONTINUE)
QUESTION:
15.Configure eBGP peers between NLFAst ISP & Uplink ISP1 , UPlink ISP2 & Cust1 routers.
- For additional practice , you will be configure the NL Fast ISP, Uplink ISP2
and Cust1 routers.
- On Connections where link redundancy is possible , peer using loopback
interface (create static route if required)
- The Cust1 router should advertise its assigned network via BGP.
- Configure authentication between all eBGP peers using a password of your choice.
- Set logical descriptions for each neighbor in the BGP Process.
- Cust1 is private-as.(64512-65535)
Solution:
---->
R1:config:
!
router bgp 1234
neighbor 11.1.1.1 remote-as 200
neighbor 11.1.1.1 description "link to ISP1"
neighbor 11.1.1.1 password cisco
neighbor 11.1.1.1 ebgp-multihop 2
neighbor 11.1.1.1 update-source Loopback1
!
R1(config-router)#do sh run | se ip route
ip route 11.1.1.1 255.255.255.255 17.9.1.1
ip route 11.1.1.1 255.255.255.255 17.9.1.5
!
R2: config:
!
router bgp 1234
neighbor 22.1.1.1 remote-as 300
neighbor 22.1.1.1 description "link to ISP2"
neighbor 22.1.1.1 password cisco
neighbor 22.1.1.1 ebgp-multihop 2
neighbor 22.1.1.1 update-source Loopback1
no auto-summary
!
R2(config-router)#do sh run | se ip route
ip route 22.1.1.1 255.255.255.255 180.1.5.1
ip route 22.1.1.1 255.255.255.255 180.1.5.5
!
R3: config:
!
router bgp 1234
neighbor 150.1.0.2 remote-as 64512
neighbor 150.1.0.2 description "Cust1 link"
no auto-summary
!
Cust1:config:
router bgp 64512
neighbor 150.1.0.1 remote-as 1234
neighbor 150.1.0.1 description "link to R3"
no auto-summary
!
ISP1:config:
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1234
neighbor 1.1.1.1 description "link to R1"
neighbor 1.1.1.1 password cisco
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback1
!
ISP1#sh run | se ip route
ip route 1.1.1.1 255.255.255.255 17.9.1.2
ip route 1.1.1.1 255.255.255.255 17.9.1.6
!
ISP2:config:
!
ISP2#sh run | se bgp
router bgp 300
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 1234
neighbor 2.2.2.2 description "link to R2"
neighbor 2.2.2.2 password cisco
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback1
no auto-summary
ISP2#sh run | se ip route
ip route 2.2.2.2 255.255.255.255 180.1.5.2
ip route 2.2.2.2 255.255.255.255 180.1.5.6
!
Output on R1:
R1(config-router)#do sh ip bgp summary
BGP router identifier 1.1.1.1, local AS number 1234
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2.2.2.2 4 1234 62 63 1 0 0 00:59:14 0
3.3.3.3 4 1234 61 62 1 0 0 00:58:37 0
4.4.4.4 4 1234 62 62 1 0 0 00:58:01 0
11.1.1.1 4 200 37 37 1 0 0 00:33:08 0
QUESTION:
15.Configure eBGP peers between NLFAst ISP & Uplink ISP1 , UPlink ISP2 & Cust1 routers.
- For additional practice , you will be configure the NL Fast ISP, Uplink ISP2
and Cust1 routers.
- On Connections where link redundancy is possible , peer using loopback
interface (create static route if required)
- The Cust1 router should advertise its assigned network via BGP.
- Configure authentication between all eBGP peers using a password of your choice.
- Set logical descriptions for each neighbor in the BGP Process.
- Cust1 is private-as.(64512-65535)
Solution:
---->
R1:config:
!
router bgp 1234
neighbor 11.1.1.1 remote-as 200
neighbor 11.1.1.1 description "link to ISP1"
neighbor 11.1.1.1 password cisco
neighbor 11.1.1.1 ebgp-multihop 2
neighbor 11.1.1.1 update-source Loopback1
!
R1(config-router)#do sh run | se ip route
ip route 11.1.1.1 255.255.255.255 17.9.1.1
ip route 11.1.1.1 255.255.255.255 17.9.1.5
!
R2: config:
!
router bgp 1234
neighbor 22.1.1.1 remote-as 300
neighbor 22.1.1.1 description "link to ISP2"
neighbor 22.1.1.1 password cisco
neighbor 22.1.1.1 ebgp-multihop 2
neighbor 22.1.1.1 update-source Loopback1
no auto-summary
!
R2(config-router)#do sh run | se ip route
ip route 22.1.1.1 255.255.255.255 180.1.5.1
ip route 22.1.1.1 255.255.255.255 180.1.5.5
!
R3: config:
!
router bgp 1234
neighbor 150.1.0.2 remote-as 64512
neighbor 150.1.0.2 description "Cust1 link"
no auto-summary
!
Cust1:config:
router bgp 64512
neighbor 150.1.0.1 remote-as 1234
neighbor 150.1.0.1 description "link to R3"
no auto-summary
!
ISP1:config:
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1234
neighbor 1.1.1.1 description "link to R1"
neighbor 1.1.1.1 password cisco
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback1
!
ISP1#sh run | se ip route
ip route 1.1.1.1 255.255.255.255 17.9.1.2
ip route 1.1.1.1 255.255.255.255 17.9.1.6
!
ISP2:config:
!
ISP2#sh run | se bgp
router bgp 300
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 1234
neighbor 2.2.2.2 description "link to R2"
neighbor 2.2.2.2 password cisco
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback1
no auto-summary
ISP2#sh run | se ip route
ip route 2.2.2.2 255.255.255.255 180.1.5.2
ip route 2.2.2.2 255.255.255.255 180.1.5.6
!
Output on R1:
R1(config-router)#do sh ip bgp summary
BGP router identifier 1.1.1.1, local AS number 1234
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2.2.2.2 4 1234 62 63 1 0 0 00:59:14 0
3.3.3.3 4 1234 61 62 1 0 0 00:58:37 0
4.4.4.4 4 1234 62 62 1 0 0 00:58:01 0
11.1.1.1 4 200 37 37 1 0 0 00:33:08 0
No comments:
Post a Comment