Wednesday 28 December 2016

BGP CHAPTER 8 (includes chap 5,6,7) FULL LAB:

BGP CHAPTER (5,6,7) FULL LAB:
13. Configure NL Fast ISP routers to use OSPF as an IGP.
- Configure network statements as a specific as possible.
- only advertise internal (private) networks.
- Use a hello interval of one second & dead of three seconds.
14. Configure full-mess iBGP peers between all routers within NLFast
(due to BGP Split Horizon)
- Peers should fail over based on the IGP if any key internal links fail
(create loopbacks as necessary)
- Disable BGP Synchronization (if necessary) .

15.Configure eBGP peers between NLFAst ISP & Uplink ISP1 , UPlink ISP2 & Cust1 routers.
- For additional practice , you will be configure the NL Fast ISP, Uplink ISP2
and Cust1 routers.
- On Connections where link redundancy is possible , peer using loopback
interface (create static route if required)
- The Cust1 router should advertise its assigned network via BGP.
- Configure authentication between all eBGP peers using a password of your choice.
- Set logical descriptions for each neighbor in the BGP Process.
- Cust1 is private-as.(64512-65535)

16.Announce networks into BGP appropriately
- ISP1 & ISP2 routers should use filtered redistribution to announce
their networks . Only advertiese loopbacks network.
- The Cust1 router should annonce its network with network command.
- The NL Fast ISP routers R1 & R2 should advertise the WAN link
subnet (currently 150.1.0.0/24) using a class C subnet mask.
17. Verification:
- Verify all expected neighbors are forming (show ip bgp summary)
- Verify all expected routes appear (show ip bgp/show ip route)
    - ISP1/ISP2 should see and be able to ping:
      . Cust1 routes
   . NL Fast ISP WAN subnet (150.1.0.0/24)
 - Cust1 should see & able to ping :
         . ISP1/ISP2 loopback networks

--------------------------------XXXXXXXXX-----------------------------------
SOLUTION:
-------> Diagram:


hostname R1
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
 ip address 17.9.1.2 255.255.255.252
 clock rate 2000000
!
interface Serial0/1
 ip address 17.9.1.6 255.255.255.252
 clock rate 2000000
!
interface Serial0/2
 ip address 10.1.1.1 255.255.255.252
 ip ospf dead-interval minimal hello-multiplier 3
 clock rate 2000000
!
interface Serial0/3
 ip address 10.1.1.5 255.255.255.252
 ip ospf dead-interval minimal hello-multiplier 3
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 redistribute static metric 50 subnets route-map OSPF_REDIS
 passive-interface Serial0/0
 passive-interface Serial0/1
 network 1.1.1.1 0.0.0.0 area 0
 network 10.1.1.0 0.0.0.3 area 0
 network 10.1.1.4 0.0.0.3 area 0
 network 17.9.1.0 0.0.0.255 area 0
 network 180.1.5.0 0.0.0.255 area 0
!
router bgp 1234
 no synchronization
 bgp log-neighbor-changes
 network 150.1.0.0 mask 255.255.255.0
 neighbor 2.2.2.2 remote-as 1234
 neighbor 2.2.2.2 update-source Loopback1
 neighbor 3.3.3.3 remote-as 1234
 neighbor 3.3.3.3 update-source Loopback1
 neighbor 4.4.4.4 remote-as 1234
 neighbor 4.4.4.4 update-source Loopback1
 neighbor 11.1.1.1 remote-as 200
 neighbor 11.1.1.1 description "link to ISP1"
 neighbor 11.1.1.1 password cisco
 neighbor 11.1.1.1 ebgp-multihop 2
 neighbor 11.1.1.1 update-source Loopback1
 neighbor 11.1.1.1 remove-private-as
 no auto-summary
!
ip forward-protocol nd
ip route 11.1.1.1 255.255.255.255 17.9.1.1
ip route 11.1.1.1 255.255.255.255 17.9.1.5
ip route 150.1.0.0 255.255.255.0 Null0
!
!
no ip http server
no ip http secure-server
!
!
ip prefix-list LOOP1 seq 10 permit 11.1.1.1/32
!
route-map OSPF_REDIS permit 10
 match ip address prefix-list LOOP1
!
!
end

hostname R2
!
interface Loopback1
 ip address 2.2.2.2 255.255.255.252
!
interface Serial0/0
 ip address 180.1.5.2 255.255.255.252
 clock rate 2000000
!
interface Serial0/1
 ip address 180.1.5.6 255.255.255.252
 clock rate 2000000
!
interface Serial0/2
 ip address 10.1.1.9 255.255.255.252
 ip ospf dead-interval minimal hello-multiplier 3
 clock rate 2000000
!
interface Serial0/3
 ip address 10.1.1.6 255.255.255.252
 ip ospf dead-interval minimal hello-multiplier 3
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 redistribute static metric 50 subnets route-map OSPF_REDIS
 passive-interface Serial0/0
 passive-interface Serial0/1
 network 2.2.2.2 0.0.0.0 area 0
 network 10.1.1.4 0.0.0.3 area 0
 network 10.1.1.8 0.0.0.3 area 0
 network 17.9.1.0 0.0.0.255 area 0
 network 180.1.5.0 0.0.0.255 area 0
!
router bgp 1234
 no synchronization
 bgp log-neighbor-changes
 network 150.1.0.0 mask 255.255.255.0
 neighbor 1.1.1.1 remote-as 1234
 neighbor 1.1.1.1 update-source Loopback1
 neighbor 3.3.3.3 remote-as 1234
 neighbor 3.3.3.3 update-source Loopback1
 neighbor 4.4.4.4 remote-as 1234
 neighbor 4.4.4.4 update-source Loopback1
 neighbor 22.1.1.1 remote-as 300
 neighbor 22.1.1.1 description "link to ISP2"
 neighbor 22.1.1.1 password cisco
 neighbor 22.1.1.1 ebgp-multihop 2
 neighbor 22.1.1.1 update-source Loopback1
 neighbor 22.1.1.1 remove-private-as
 no auto-summary
!
ip forward-protocol nd
ip route 22.1.1.1 255.255.255.255 180.1.5.1
ip route 22.1.1.1 255.255.255.255 180.1.5.5
ip route 150.1.0.0 255.255.255.0 Null0
!
!
no ip http server
no ip http secure-server
!
!
ip prefix-list LOOP1 seq 10 permit 22.1.1.1/32
!
route-map OSPF_REDIS permit 10
 match ip address prefix-list LOOP1
!
!
end

hostname R3
!
interface Loopback1
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
 ip address 150.1.0.1 255.255.255.252
 clock rate 2000000
!
interface Serial0/1
 ip address 10.1.1.13 255.255.255.252
 ip ospf dead-interval minimal hello-multiplier 3
 clock rate 2000000
!
interface Serial0/2
 ip address 10.1.1.2 255.255.255.252
 ip ospf dead-interval minimal hello-multiplier 3
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 passive-interface Serial0/0
 network 3.3.3.3 0.0.0.0 area 0
 network 10.1.1.0 0.0.0.3 area 0
 network 10.1.1.12 0.0.0.3 area 0
 network 150.1.0.1 0.0.0.0 area 0
!
router bgp 1234
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 1234
 neighbor 1.1.1.1 update-source Loopback1
 neighbor 2.2.2.2 remote-as 1234
 neighbor 2.2.2.2 update-source Loopback1
 neighbor 4.4.4.4 remote-as 1234
 neighbor 4.4.4.4 update-source Loopback1
 neighbor 150.1.0.2 remote-as 64512
 neighbor 150.1.0.2 description "Cust1 link"
 neighbor 150.1.0.2 default-originate
 no auto-summary
!
end


!
hostname R4
!
interface Loopback1
 ip address 4.4.4.4 255.255.255.255
!
interface Serial0/1
 ip address 10.1.1.14 255.255.255.252
 ip ospf dead-interval minimal hello-multiplier 3
 clock rate 2000000
!
interface Serial0/2
 ip address 10.1.1.10 255.255.255.252
 ip ospf dead-interval minimal hello-multiplier 3
 clock rate 2000000
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 10.1.1.8 0.0.0.3 area 0
 network 10.1.1.12 0.0.0.3 area 0
!
router bgp 1234
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 1234
 neighbor 1.1.1.1 update-source Loopback1
 neighbor 2.2.2.2 remote-as 1234
 neighbor 2.2.2.2 update-source Loopback1
 neighbor 3.3.3.3 remote-as 1234
 neighbor 3.3.3.3 update-source Loopback1
 no auto-summary
!
end

!
hostname ISP1
!
interface Loopback1
 ip address 11.1.1.1 255.255.255.255
!
interface Loopback2
 ip address 11.1.1.2 255.255.255.255
!
interface Loopback3
 ip address 11.1.1.3 255.255.255.255
!
interface Serial0/0
 ip address 17.9.1.1 255.255.255.252
 clock rate 2000000
!
interface Serial0/1
 ip address 17.9.1.5 255.255.255.252
 clock rate 2000000
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 redistribute connected route-map RLOOP
 neighbor 1.1.1.1 remote-as 1234
 neighbor 1.1.1.1 description "link to R1"
 neighbor 1.1.1.1 password cisco
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 update-source Loopback1
 no auto-summary
!
ip forward-protocol nd
ip route 1.1.1.1 255.255.255.255 17.9.1.2
ip route 1.1.1.1 255.255.255.255 17.9.1.6
!
!
ip prefix-list LOOP seq 10 permit 11.1.1.1/32
ip prefix-list LOOP seq 20 permit 11.1.1.2/32
ip prefix-list LOOP seq 30 permit 11.1.1.3/32
!
route-map RLOOP permit 10
 match ip address prefix-list LOOP
!
end


hostname ISP2
!
!
interface Loopback1
 ip address 22.1.1.1 255.255.255.255
!
interface Loopback2
 ip address 22.1.1.2 255.255.255.255
!
interface Loopback3
 ip address 22.1.1.3 255.255.255.255
!
interface Serial0/0
 ip address 180.1.5.1 255.255.255.252
 clock rate 2000000
!
interface Serial0/1
 ip address 180.1.5.5 255.255.255.252
 clock rate 2000000
!
router bgp 300
 no synchronization
 bgp log-neighbor-changes
 redistribute connected route-map RLOOP
 neighbor 2.2.2.2 remote-as 1234
 neighbor 2.2.2.2 description "link to R2"
 neighbor 2.2.2.2 password cisco
 neighbor 2.2.2.2 ebgp-multihop 2
 neighbor 2.2.2.2 update-source Loopback1
 no auto-summary
!
ip forward-protocol nd
ip route 2.2.2.2 255.255.255.255 180.1.5.2
ip route 2.2.2.2 255.255.255.255 180.1.5.6
!
!
no ip http server
no ip http secure-server
!
!
ip prefix-list LOOP seq 10 permit 22.1.1.1/32
ip prefix-list LOOP seq 20 permit 22.1.1.2/32
ip prefix-list LOOP seq 30 permit 22.1.1.3/32
!
route-map RLOOP permit 10
 match ip address prefix-list LOOP
!
end

hostname Cust1
!
interface FastEthernet0/0
 ip address 150.1.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 150.1.0.2 255.255.255.252
 clock rate 2000000
!
router bgp 64512
 no synchronization
 bgp log-neighbor-changes
 network 150.1.1.0 mask 255.255.255.0
 neighbor 150.1.0.1 remote-as 1234
 neighbor 150.1.0.1 description "link to R3"
 no auto-summary
!
end

No comments:

Post a Comment