CCNP TSHOOT CHAPTER 7 (EIGRP ADj)
12. What are the possible issues for Eigrp adj formatoin ?
13. What are common issues to build eigrp routes ?
-->
Solution:
1. Network Properly not configured.
!
sh ip protocols
!
2. AS-number must match.
3. By default it uses multicast , to stop multicast we can use neighbour commad.
! neighbour 10.0.0.55 s0/1
4. Authentication issues
!
# sh run int s1/0 | in authen
sh key chain
!
5. K-values must match.
6. Check passive interface plus L1/L2/L3 issues
7. Eigrp Masks and timers "do not" have to always be an exact match.
sh ip eig interface
sh ip protocols
sh ip eigrp neigh
show interfa s1/0 | in Encapsulation|Internet address
8. for slow links eigrp send hellos after 60 sec in fast link it send pkt after 5 secs.
13. What are common issues to build eigrp routes ?
-->
1. First check the adjacency table : with show ip eigrp neighbour command
2. Is Distribute list blocking any route.
3. Check auto-summary command.
4. Is any eigrp stub is configured .
5. Check in the network same Router-id is configured.
Check outputs in case of eigrp :
1.1.1.1(L1)---R1(10.1.1.1/24)-----------------10.1.1.2/24(R2)----2.2.2.2(L1)
R1
!
!
hostname R1
!
!
key chain RAT
key 1
key-string cisco
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
ip authentication mode eigrp 10 md5
ip authentication key-chain eigrp 10 RAT
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 10
network 1.0.0.0
network 10.0.0.0
no auto-summary
!
end
!
hostname R2
!
key chain RAT
key 1
key-string cisco
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.0
ip authentication mode eigrp 10 md5
ip authentication key-chain eigrp 10 RAT
duplex auto
speed auto
!
router eigrp 10
network 2.0.0.0
network 10.0.0.0
no auto-summary
!
----------------- OUTPUTs
R2#sh ip protocols
Routing Protocol is "eigrp 10"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 10
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
2.0.0.0
10.0.0.0
Routing Information Sources:
Gateway Distance Last Update
10.1.1.1 90 00:02:21
Distance: internal 90 external 170
R2#sh run int fa0/0 | in authentication
ip authentication mode eigrp 10 md5
ip authentication key-chain eigrp 10 RAT
R2#sh key chain
Key-chain RAT:
key 1 -- text "cisco"
accept lifetime (always valid) - (always valid) [valid now]
send lifetime (always valid) - (always valid) [valid now]
R2#sh ip eigrp interface
IP-EIGRP interfaces for process 10
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Lo1 0 0/0 0 0/1 0 0
Fa0/0 1 0/0 56 0/2 276 0
R2#sh ip eigrp neighbor
IP-EIGRP neighbors for process 10
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.1.1 Fa0/0 12 00:04:03 56 336 0 8
R2#sh interfaces fa0/0 | in Encapsulation|Internet address
Internet address is 10.1.1.2/24
Encapsulation ARPA, loopback not set
12. What are the possible issues for Eigrp adj formatoin ?
13. What are common issues to build eigrp routes ?
-->
Solution:
1. Network Properly not configured.
!
sh ip protocols
!
2. AS-number must match.
3. By default it uses multicast , to stop multicast we can use neighbour commad.
! neighbour 10.0.0.55 s0/1
4. Authentication issues
!
# sh run int s1/0 | in authen
sh key chain
!
5. K-values must match.
6. Check passive interface plus L1/L2/L3 issues
7. Eigrp Masks and timers "do not" have to always be an exact match.
sh ip eig interface
sh ip protocols
sh ip eigrp neigh
show interfa s1/0 | in Encapsulation|Internet address
8. for slow links eigrp send hellos after 60 sec in fast link it send pkt after 5 secs.
13. What are common issues to build eigrp routes ?
-->
1. First check the adjacency table : with show ip eigrp neighbour command
2. Is Distribute list blocking any route.
3. Check auto-summary command.
4. Is any eigrp stub is configured .
5. Check in the network same Router-id is configured.
Check outputs in case of eigrp :
1.1.1.1(L1)---R1(10.1.1.1/24)-----------------10.1.1.2/24(R2)----2.2.2.2(L1)
R1
!
!
hostname R1
!
!
key chain RAT
key 1
key-string cisco
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
ip authentication mode eigrp 10 md5
ip authentication key-chain eigrp 10 RAT
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 10
network 1.0.0.0
network 10.0.0.0
no auto-summary
!
end
!
hostname R2
!
key chain RAT
key 1
key-string cisco
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.0
ip authentication mode eigrp 10 md5
ip authentication key-chain eigrp 10 RAT
duplex auto
speed auto
!
router eigrp 10
network 2.0.0.0
network 10.0.0.0
no auto-summary
!
----------------- OUTPUTs
R2#sh ip protocols
Routing Protocol is "eigrp 10"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 10
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
2.0.0.0
10.0.0.0
Routing Information Sources:
Gateway Distance Last Update
10.1.1.1 90 00:02:21
Distance: internal 90 external 170
R2#sh run int fa0/0 | in authentication
ip authentication mode eigrp 10 md5
ip authentication key-chain eigrp 10 RAT
R2#sh key chain
Key-chain RAT:
key 1 -- text "cisco"
accept lifetime (always valid) - (always valid) [valid now]
send lifetime (always valid) - (always valid) [valid now]
R2#sh ip eigrp interface
IP-EIGRP interfaces for process 10
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Lo1 0 0/0 0 0/1 0 0
Fa0/0 1 0/0 56 0/2 276 0
R2#sh ip eigrp neighbor
IP-EIGRP neighbors for process 10
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.1.1 Fa0/0 12 00:04:03 56 336 0 8
R2#sh interfaces fa0/0 | in Encapsulation|Internet address
Internet address is 10.1.1.2/24
Encapsulation ARPA, loopback not set
No comments:
Post a Comment