BGP CHAPTER 5 (LAB)
QUESTIONS:
ACCORDING TO DIAGRAM:
13. Configure NL Fast ISP routers to use OSPF as an IGP.
- Configure network statements as a specific as possible.
- only advertise internal (private) networks.
- Use a hello interval of one second & dead of three seconds.
14. Configure full-mess iBGP peers between all routers within NLFast
(due to BGP Split Horizon)
- Peers should fail over based on the IGP if any key internal links fail
(create loopbacks as necessary)
- Disable BGP Synchronization (if necessary) .
SOLUTION:
13. Configure NL Fast ISP routers to use OSPF as an IGP.
- Configure network statements as a specific as possible.
- only advertise internal (private) networks.
- Use a hello interval of one second & dead of three seconds.
------>
R1:config:
R1#sh run | se ospf
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 10.1.1.0 0.0.0.3 area 0
network 10.1.1.4 0.0.0.3 area 0
!
interface Serial0/2
ip address 10.1.1.1 255.255.255.252
ip ospf dead-interval minimal hello-multiplier 3
clock rate 2000000
end
R1#sh run int s0/3
Building configuration...
Current configuration : 134 bytes
!
interface Serial0/3
ip address 10.1.1.5 255.255.255.252
ip ospf dead-interval minimal hello-multiplier 3
clock rate 2000000
end
!
R2:config :
!
router ospf 1
network 2.2.2.2 0.0.0.0 area 0
network 10.1.1.4 0.0.0.3 area 0
network 10.1.1.8 0.0.0.3 area 0
!
!
interface Serial0/2
ip address 10.1.1.9 255.255.255.252
ip ospf dead-interval minimal hello-multiplier 3
clock rate 2000000
end
R2#sh run int s0/3
Building configuration...
Current configuration : 134 bytes
!
interface Serial0/3
ip address 10.1.1.6 255.255.255.252
ip ospf dead-interval minimal hello-multiplier 3
clock rate 2000000
end
!
R3 config :
!
R3#sh run | se ospf
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 10.1.1.0 0.0.0.3 area 0
network 10.1.1.12 0.0.0.3 area 0
!
!
interface Serial0/2
ip address 10.1.1.2 255.255.255.252
ip ospf dead-interval minimal hello-multiplier 3
clock rate 2000000
end
!
interface Serial0/1
ip address 10.1.1.13 255.255.255.252
ip ospf dead-interval minimal hello-multiplier 3
clock rate 2000000
end
!
R4: config:
!
R4(config-router)#do sh run | se ospf
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 10.1.1.8 0.0.0.3 area 0
network 10.1.1.12 0.0.0.3 area 0
!
!
interface Serial0/2
ip address 10.1.1.10 255.255.255.252
ip ospf dead-interval minimal hello-multiplier 3
clock rate 2000000
end
!
interface Serial0/1
ip address 10.1.1.14 255.255.255.252
ip ospf dead-interval minimal hello-multiplier 3
clock rate 2000000
end
14. Configure full-mess iBGP peers between all routers within NLFast
(due to BGP Split Horizon)
- Peers should fail over based on the IGP if any key internal links fail
(create loopbacks as necessary)
- Disable BGP Synchronization (if necessary) .
------->
R1: Config :
R1#sh run | se bgp
!
router bgp 1234
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 1234
neighbor 2.2.2.2 update-source Loopback1
neighbor 3.3.3.3 remote-as 1234
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 1234
neighbor 4.4.4.4 update-source Loopback1
no auto-summary
!
R1#sh ip bgp su
BGP router identifier 1.1.1.1, local AS number 1234
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2.2.2.2 4 1234 13 14 1 0 0 00:10:17 0
3.3.3.3 4 1234 12 13 1 0 0 00:09:40 0
4.4.4.4 4 1234 13 13 1 0 0 00:09:04 0
!
R2: config :
R2#sh run | se bgp
router bgp 1234
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1234
neighbor 1.1.1.1 update-source Loopback1
neighbor 3.3.3.3 remote-as 1234
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 1234
neighbor 4.4.4.4 update-source Loopback1
no auto-summary
!
R2#sh ip bgp summary
BGP router identifier 2.2.2.2, local AS number 1234
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.1 4 1234 14 13 1 0 0 00:10:55 0
3.3.3.3 4 1234 13 13 1 0 0 00:09:53 0
4.4.4.4 4 1234 13 13 1 0 0 00:09:13 0
!
R3: config:
!
R3#sh run | se bgp
router bgp 1234
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1234
neighbor 1.1.1.1 update-source Loopback1
neighbor 2.2.2.2 remote-as 1234
neighbor 2.2.2.2 update-source Loopback1
neighbor 4.4.4.4 remote-as 1234
neighbor 4.4.4.4 update-source Loopback1
no auto-summary
!
R3#sh ip bgp su
BGP router identifier 3.3.3.3, local AS number 1234
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.1 4 1234 15 14 1 0 0 00:11:22 0
2.2.2.2 4 1234 14 14 1 0 0 00:10:58 0
4.4.4.4 4 1234 14 14 1 0 0 00:10:07 0
!
R4(config-router)#do sh run | se bgp
router bgp 1234
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1234
neighbor 1.1.1.1 update-source Loopback1
neighbor 2.2.2.2 remote-as 1234
neighbor 2.2.2.2 update-source Loopback1
neighbor 3.3.3.3 remote-as 1234
neighbor 3.3.3.3 update-source Loopback1
no auto-summary
!
R4(config-router)#do sh ip bgp summary
BGP router identifier 4.4.4.4, local AS number 1234
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.1 4 1234 15 15 1 0 0 00:11:30 0
2.2.2.2 4 1234 15 15 1 0 0 00:11:01 0
3.3.3.3 4 1234 14 14 1 0 0 00:10:50 0
!
QUESTIONS:
ACCORDING TO DIAGRAM:
13. Configure NL Fast ISP routers to use OSPF as an IGP.
- Configure network statements as a specific as possible.
- only advertise internal (private) networks.
- Use a hello interval of one second & dead of three seconds.
14. Configure full-mess iBGP peers between all routers within NLFast
(due to BGP Split Horizon)
- Peers should fail over based on the IGP if any key internal links fail
(create loopbacks as necessary)
- Disable BGP Synchronization (if necessary) .
SOLUTION:
13. Configure NL Fast ISP routers to use OSPF as an IGP.
- Configure network statements as a specific as possible.
- only advertise internal (private) networks.
- Use a hello interval of one second & dead of three seconds.
------>
R1:config:
R1#sh run | se ospf
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 10.1.1.0 0.0.0.3 area 0
network 10.1.1.4 0.0.0.3 area 0
!
interface Serial0/2
ip address 10.1.1.1 255.255.255.252
ip ospf dead-interval minimal hello-multiplier 3
clock rate 2000000
end
R1#sh run int s0/3
Building configuration...
Current configuration : 134 bytes
!
interface Serial0/3
ip address 10.1.1.5 255.255.255.252
ip ospf dead-interval minimal hello-multiplier 3
clock rate 2000000
end
!
R2:config :
!
router ospf 1
network 2.2.2.2 0.0.0.0 area 0
network 10.1.1.4 0.0.0.3 area 0
network 10.1.1.8 0.0.0.3 area 0
!
!
interface Serial0/2
ip address 10.1.1.9 255.255.255.252
ip ospf dead-interval minimal hello-multiplier 3
clock rate 2000000
end
R2#sh run int s0/3
Building configuration...
Current configuration : 134 bytes
!
interface Serial0/3
ip address 10.1.1.6 255.255.255.252
ip ospf dead-interval minimal hello-multiplier 3
clock rate 2000000
end
!
R3 config :
!
R3#sh run | se ospf
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 10.1.1.0 0.0.0.3 area 0
network 10.1.1.12 0.0.0.3 area 0
!
!
interface Serial0/2
ip address 10.1.1.2 255.255.255.252
ip ospf dead-interval minimal hello-multiplier 3
clock rate 2000000
end
!
interface Serial0/1
ip address 10.1.1.13 255.255.255.252
ip ospf dead-interval minimal hello-multiplier 3
clock rate 2000000
end
!
R4: config:
!
R4(config-router)#do sh run | se ospf
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 10.1.1.8 0.0.0.3 area 0
network 10.1.1.12 0.0.0.3 area 0
!
!
interface Serial0/2
ip address 10.1.1.10 255.255.255.252
ip ospf dead-interval minimal hello-multiplier 3
clock rate 2000000
end
!
interface Serial0/1
ip address 10.1.1.14 255.255.255.252
ip ospf dead-interval minimal hello-multiplier 3
clock rate 2000000
end
14. Configure full-mess iBGP peers between all routers within NLFast
(due to BGP Split Horizon)
- Peers should fail over based on the IGP if any key internal links fail
(create loopbacks as necessary)
- Disable BGP Synchronization (if necessary) .
------->
R1: Config :
R1#sh run | se bgp
!
router bgp 1234
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 1234
neighbor 2.2.2.2 update-source Loopback1
neighbor 3.3.3.3 remote-as 1234
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 1234
neighbor 4.4.4.4 update-source Loopback1
no auto-summary
!
R1#sh ip bgp su
BGP router identifier 1.1.1.1, local AS number 1234
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2.2.2.2 4 1234 13 14 1 0 0 00:10:17 0
3.3.3.3 4 1234 12 13 1 0 0 00:09:40 0
4.4.4.4 4 1234 13 13 1 0 0 00:09:04 0
!
R2: config :
R2#sh run | se bgp
router bgp 1234
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1234
neighbor 1.1.1.1 update-source Loopback1
neighbor 3.3.3.3 remote-as 1234
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 1234
neighbor 4.4.4.4 update-source Loopback1
no auto-summary
!
R2#sh ip bgp summary
BGP router identifier 2.2.2.2, local AS number 1234
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.1 4 1234 14 13 1 0 0 00:10:55 0
3.3.3.3 4 1234 13 13 1 0 0 00:09:53 0
4.4.4.4 4 1234 13 13 1 0 0 00:09:13 0
!
R3: config:
!
R3#sh run | se bgp
router bgp 1234
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1234
neighbor 1.1.1.1 update-source Loopback1
neighbor 2.2.2.2 remote-as 1234
neighbor 2.2.2.2 update-source Loopback1
neighbor 4.4.4.4 remote-as 1234
neighbor 4.4.4.4 update-source Loopback1
no auto-summary
!
R3#sh ip bgp su
BGP router identifier 3.3.3.3, local AS number 1234
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.1 4 1234 15 14 1 0 0 00:11:22 0
2.2.2.2 4 1234 14 14 1 0 0 00:10:58 0
4.4.4.4 4 1234 14 14 1 0 0 00:10:07 0
!
R4(config-router)#do sh run | se bgp
router bgp 1234
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1234
neighbor 1.1.1.1 update-source Loopback1
neighbor 2.2.2.2 remote-as 1234
neighbor 2.2.2.2 update-source Loopback1
neighbor 3.3.3.3 remote-as 1234
neighbor 3.3.3.3 update-source Loopback1
no auto-summary
!
R4(config-router)#do sh ip bgp summary
BGP router identifier 4.4.4.4, local AS number 1234
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.1 4 1234 15 15 1 0 0 00:11:30 0
2.2.2.2 4 1234 15 15 1 0 0 00:11:01 0
3.3.3.3 4 1234 14 14 1 0 0 00:10:50 0
!
No comments:
Post a Comment