BGP CHAPTER 13 (CONFEDERATION)
QUESTION:
26. What is Confederation ?
27. How to Design Confederation ?
--> Lab on Confederation .
Solution:
26. What is Confederation ?
-->
. An AS inside an AS
. Alternative to route reflections
. uses intra-as numbers , which are stripped before sending updates via EBGP.
. Inter-confederation peers are treated as EBGP to establish, but IBGP relating to
attributes.
. Still on IGP for the entire system
27. How to Design Confederation ?
-->
. Complete BGP rewrite.
. Break AS into smaller autonomous systems
. use private AS numbers (64512-65535)
. full ibgp mesh required within confederation AS (Route reflectors an option)
--> Lab on Confederation .
--> Diagram:
!
hostname R3
!
!
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.23.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 10.1.23.0 0.0.0.255 area 0
!
router bgp 65003
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 123
bgp confederation peers 65002
neighbor 2.2.2.2 remote-as 65002
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback1
no auto-summary
!
!
end
QUESTION:
26. What is Confederation ?
27. How to Design Confederation ?
--> Lab on Confederation .
Solution:
26. What is Confederation ?
-->
. An AS inside an AS
. Alternative to route reflections
. uses intra-as numbers , which are stripped before sending updates via EBGP.
. Inter-confederation peers are treated as EBGP to establish, but IBGP relating to
attributes.
. Still on IGP for the entire system
27. How to Design Confederation ?
-->
. Complete BGP rewrite.
. Break AS into smaller autonomous systems
. use private AS numbers (64512-65535)
. full ibgp mesh required within confederation AS (Route reflectors an option)
--> Lab on Confederation .
--> Diagram:
Create sub-as on R1,R2,R3 as in diagram.
Config:
R1:
!
hostname R2
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.23.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.12.2 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 10.1.12.0 0.0.0.255 area 0
network 10.1.23.0 0.0.0.255 area 0
!
router bgp 65002
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 123
bgp confederation peers 65001 65003
neighbor 1.1.1.1 remote-as 65001
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback1
neighbor 3.3.3.3 remote-as 65003
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source Loopback1
no auto-summary
!
!
end
!
hostname R2
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.23.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.12.2 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 10.1.12.0 0.0.0.255 area 0
network 10.1.23.0 0.0.0.255 area 0
!
router bgp 65002
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 123
bgp confederation peers 65001 65003
neighbor 1.1.1.1 remote-as 65001
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback1
neighbor 3.3.3.3 remote-as 65003
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source Loopback1
no auto-summary
!
!
end
!
hostname R3
!
!
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.23.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 10.1.23.0 0.0.0.255 area 0
!
router bgp 65003
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 123
bgp confederation peers 65002
neighbor 2.2.2.2 remote-as 65002
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback1
no auto-summary
!
!
end
!
hostname R4
!
!
interface Loopback1
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.14.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 54
no synchronization
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
neighbor 10.1.14.1 remote-as 123
no auto-summary
!
end
--------- output ---- on R2, R3 ----------
R2#sh ip bgp
BGP table version is 2, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 4.4.4.4/32 10.1.14.4 0 100 0 (65001) 54 i
R3#sh ip bgp
BGP table version is 2, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 4.4.4.4/32 10.1.14.4 0 100 0 (65002 65001) 54 i
No comments:
Post a Comment