BGP CHAPTER 12 (ROUTE-REFLECTION)
QUESTION:
25b. What is Route-Reflection ?
-->Perform Lab for Route-reflection .
25b. What is Route-Reflection ?
Solution:
--> RRs Bend the BGP Split Horizon rules.
. RRs Process updates as follows:
- eBGP Peer --> All iBGP / eBGP peers.
- iBGP (non-client) Peer --> eBGP and Clients
- iBGP (client) Peer --> All Peers (Non-sender)
. RR Groups add a cluster-id attribute to routes
. RR clients are oblivious to everything .
-->Perform Lab for Route-reflection .
According to diagram:
-->
The updates for BB3 via eBGP go to the R4, R4 will forward updates via
iBGP to R1, but due to split horizon R1 will not forward updates to the R3.
Now we can make R1, BGP route-reflector then it forward the updates to
the non-client also.
R1,R4,R3, BB3 config:
!
hostname R1
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.14.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.13.1 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 10.1.13.0 0.0.0.255 area 0
network 10.1.14.0 0.0.0.255 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 3.3.3.3 route-reflector-client
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
no auto-summary
!
ip forward-protocol nd
!
end
QUESTION:
25b. What is Route-Reflection ?
-->Perform Lab for Route-reflection .
25b. What is Route-Reflection ?
Solution:
--> RRs Bend the BGP Split Horizon rules.
. RRs Process updates as follows:
- eBGP Peer --> All iBGP / eBGP peers.
- iBGP (non-client) Peer --> eBGP and Clients
- iBGP (client) Peer --> All Peers (Non-sender)
. RR Groups add a cluster-id attribute to routes
. RR clients are oblivious to everything .
-->Perform Lab for Route-reflection .
According to diagram:
-->
The updates for BB3 via eBGP go to the R4, R4 will forward updates via
iBGP to R1, but due to split horizon R1 will not forward updates to the R3.
Now we can make R1, BGP route-reflector then it forward the updates to
the non-client also.
R1,R4,R3, BB3 config:
!
hostname R1
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.14.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.13.1 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 10.1.13.0 0.0.0.255 area 0
network 10.1.14.0 0.0.0.255 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 3.3.3.3 route-reflector-client
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
no auto-summary
!
ip forward-protocol nd
!
end
!
hostname R3
!
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.13.3 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 10.1.13.0 0.0.0.255 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
no auto-summary
!
end
!
hostname R4
!
interface Loopback1
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.14.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 204.12.1.4 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
passive-interface FastEthernet0/1
network 4.4.4.4 0.0.0.0 area 0
network 10.1.14.0 0.0.0.255 area 0
network 204.12.1.0 0.0.0.255 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 204.12.1.254 remote-as 54
no auto-summary
!
end
hostname BB3
!
interface Loopback1
ip address 33.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 204.12.1.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 54
no synchronization
bgp log-neighbor-changes
network 33.1.1.1 mask 255.255.255.255
neighbor 204.12.1.4 remote-as 100
no auto-summary
!
end
output at R3:
R3 getting routes from R1.........WoW !!!!!!
R3#sh ip bg
BGP table version is 2, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i33.1.1.1/32 204.12.1.254 0 100 0 54 i
No comments:
Post a Comment