BGP CHAPTER 15(Peer_groups_lab)
30. What is peer-groups in BGP ?
--> Lab on BGP Peer-groups .
31. What is BGP route Dampening ?
-->
Solution:
30. What is peer-groups in BGP ?
--> Lab on BGP Peer-groups .
. Efficient way of neighbour configuration.
. Separate peer for IBGP & EBGP
. Generates a single outbound update for all the peers.
. Individual configuration supported for inbound updates.
. Handled dynamically in IOS 12.0 (show ip bgp update-gorup)
Lab:
diagram--->
!
hostname R5
!
!
interface Loopback1
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.45.5 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 555
no synchronization
bgp log-neighbor-changes
network 5.5.5.5 mask 255.255.255.255
neighbor 10.1.45.4 remote-as 1234
no auto-summary
!
end
31. What is BGP route Dampening ?
-->
.Suppress the impact of flapping routes without impacting better routes.
.Default mechanish: 5 seconds 'wait' for iBGP & 30 second 'wait' for eBGP.
.Works like a water beaker:
- penalty - 1000
- Suppress limit - 2000
- Reuse limit - 750
- Decay algorithm (half-life) - 15 min
30. What is peer-groups in BGP ?
--> Lab on BGP Peer-groups .
31. What is BGP route Dampening ?
-->
Solution:
30. What is peer-groups in BGP ?
--> Lab on BGP Peer-groups .
. Efficient way of neighbour configuration.
. Separate peer for IBGP & EBGP
. Generates a single outbound update for all the peers.
. Individual configuration supported for inbound updates.
. Handled dynamically in IOS 12.0 (show ip bgp update-gorup)
Lab:
diagram--->
R1-R5 configs:
hostname R1
!
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.13.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 10.1.12.0 0.0.0.255 area 0
network 10.1.13.0 0.0.0.255 area 0
!
router bgp 1234
no synchronization
bgp log-neighbor-changes
neighbor IBGP_PEERS peer-group
neighbor IBGP_PEERS remote-as 1234
neighbor IBGP_PEERS update-source Loopback1
neighbor 2.2.2.2 peer-group IBGP_PEERS
neighbor 3.3.3.3 peer-group IBGP_PEERS
neighbor 4.4.4.4 peer-group IBGP_PEERS
no auto-summary
!
end
!
hostname R2
!
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.24.2 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 10.1.12.0 0.0.0.255 area 0
network 10.1.24.0 0.0.0.255 area 0
!
router bgp 1234
no synchronization
bgp log-neighbor-changes
neighbor IBGP_PEERS peer-group
neighbor IBGP_PEERS remote-as 1234
neighbor IBGP_PEERS update-source Loopback1
neighbor 1.1.1.1 peer-group IBGP_PEERS
neighbor 3.3.3.3 peer-group IBGP_PEERS
neighbor 4.4.4.4 peer-group IBGP_PEERS
no auto-summary
!
!
end
!
hostname R3
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.34.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.13.3 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 10.1.13.0 0.0.0.255 area 0
network 10.1.34.0 0.0.0.255 area 0
!
router bgp 1234
no synchronization
bgp log-neighbor-changes
neighbor IBGP_PEERS peer-group
neighbor IBGP_PEERS remote-as 1234
neighbor IBGP_PEERS update-source Loopback1
neighbor 1.1.1.1 peer-group IBGP_PEERS
neighbor 2.2.2.2 peer-group IBGP_PEERS
neighbor 4.4.4.4 peer-group IBGP_PEERS
no auto-summary
!
end
hostname R4
!
interface Loopback1
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.34.4 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.45.4 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip address 10.1.24.4 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
passive-interface Serial0/0
network 4.4.4.4 0.0.0.0 area 0
network 10.1.24.0 0.0.0.255 area 0
network 10.1.34.0 0.0.0.255 area 0
network 10.1.45.0 0.0.0.255 area 0
!
router bgp 1234
no synchronization
bgp log-neighbor-changes
neighbor IBGP_PEERS peer-group
neighbor IBGP_PEERS remote-as 1234
neighbor IBGP_PEERS update-source Loopback1
neighbor 1.1.1.1 peer-group IBGP_PEERS
neighbor 2.2.2.2 peer-group IBGP_PEERS
neighbor 3.3.3.3 peer-group IBGP_PEERS
neighbor 10.1.45.5 remote-as 555
no auto-summary
!
end
!
hostname R5
!
!
interface Loopback1
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.45.5 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 555
no synchronization
bgp log-neighbor-changes
network 5.5.5.5 mask 255.255.255.255
neighbor 10.1.45.4 remote-as 1234
no auto-summary
!
end
-------------------------------------------------
31. What is BGP route Dampening ?
-->
.Suppress the impact of flapping routes without impacting better routes.
.Default mechanish: 5 seconds 'wait' for iBGP & 30 second 'wait' for eBGP.
.Works like a water beaker:
- penalty - 1000
- Suppress limit - 2000
- Reuse limit - 750
- Decay algorithm (half-life) - 15 min
No comments:
Post a Comment