MPLS CHAPTER 11 (TROUBLESHOOTING & FULL CONFIG )
In this blog you will get full config & troubleshooting steps:
Points:
1. VRF ( RD , RT import -- RT export )
2. Assign VRF
3. Enable VRF aware Routing Process
4. VPNv4 Peers ( PE routers redistibuted routes)
5. Redistribution
Troubleshooting of mpls vpn
we check the control plan & data plan
sh ip vrf
sh ip vrf detail
- we can check the import and export
sh ip route vrf Cust_site1
- checking routes are coming or not
sh bgp vpnv4 unicast vrf Cust_site2
- it is redistributed on bgp or not
sh bgp vpnv4 unicast vrf Cust_site1 4.4.4.1/32
attributes of vrf
debug mpls packates
sh bgp vpnv4 unicast all
sh bgp vpnv4 unicast all 4.4.4.1/32
sh mpls interfaces
To check the mpls labels :
trasport label| vpnv4 label| payload
which PE which Customer
26|25|icmp
25 is vpnv4 label not changed . it will changed at PE router.
sh ip bgp vpnv4 rd 1.1.1.1:1 labels
sh ip bgp vpnv4 rd 1.1.1.1:2 labels
sh bgp vpnv4 unicast vrf Cust_site1 labels
sh bgp vpnv4 unicast vrf Cust_site2 labels
sh ip cef vrf Cust_site1 4.4.4.1
sh ip cef vrf Cust_site1 6.6.6.1
PE0R1#sh ip cef vrf Cust_site1 6.6.6.1
6.6.6.1/32, version 22, epoch 0, cached adjacency 10.1.12.2
0 packets, 0 bytes
tag information set
local tag: VPN-route-head
fast tag rewrite with Fa0/0, 10.1.12.2, tags imposed: {16 21}
via 3.3.3.3, 0 dependencies, recursive
next hop 10.1.12.2, FastEthernet0/0 via 3.3.3.3/32
valid cached adjacency
tag rewrite with Fa0/0, 10.1.12.2, tags imposed: {16 21}
{16 21} here : 16 is top label and 21 is vpn label .
===============================================================
config file of this lab:
diag :
In this blog you will get full config & troubleshooting steps:
Points:
1. VRF ( RD , RT import -- RT export )
2. Assign VRF
3. Enable VRF aware Routing Process
4. VPNv4 Peers ( PE routers redistibuted routes)
5. Redistribution
Troubleshooting of mpls vpn
we check the control plan & data plan
sh ip vrf
sh ip vrf detail
- we can check the import and export
sh ip route vrf Cust_site1
- checking routes are coming or not
sh bgp vpnv4 unicast vrf Cust_site2
- it is redistributed on bgp or not
sh bgp vpnv4 unicast vrf Cust_site1 4.4.4.1/32
attributes of vrf
debug mpls packates
sh bgp vpnv4 unicast all
sh bgp vpnv4 unicast all 4.4.4.1/32
sh mpls interfaces
To check the mpls labels :
trasport label| vpnv4 label| payload
which PE which Customer
26|25|icmp
25 is vpnv4 label not changed . it will changed at PE router.
sh ip bgp vpnv4 rd 1.1.1.1:1 labels
sh ip bgp vpnv4 rd 1.1.1.1:2 labels
sh bgp vpnv4 unicast vrf Cust_site1 labels
sh bgp vpnv4 unicast vrf Cust_site2 labels
sh ip cef vrf Cust_site1 4.4.4.1
sh ip cef vrf Cust_site1 6.6.6.1
PE0R1#sh ip cef vrf Cust_site1 6.6.6.1
6.6.6.1/32, version 22, epoch 0, cached adjacency 10.1.12.2
0 packets, 0 bytes
tag information set
local tag: VPN-route-head
fast tag rewrite with Fa0/0, 10.1.12.2, tags imposed: {16 21}
via 3.3.3.3, 0 dependencies, recursive
next hop 10.1.12.2, FastEthernet0/0 via 3.3.3.3/32
valid cached adjacency
tag rewrite with Fa0/0, 10.1.12.2, tags imposed: {16 21}
{16 21} here : 16 is top label and 21 is vpn label .
===============================================================
config file of this lab:
diag :
----- Config----
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE0R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip vrf Cust_site1
rd 1.1.1.1:1
route-target export 1.1.1.1:101
route-target import 3.3.3.3:101
!
ip vrf Cust_site2
rd 1.1.1.1:2
route-target export 1.1.1.1:102
route-target import 3.3.3.3:102
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
mpls label range 500 599
!
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial0/0
ip vrf forwarding Cust_site2
ip address 10.1.15.1 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding Cust_site1
ip address 10.1.14.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router eigrp 1
auto-summary
!
address-family ipv4 vrf Cust_site2
redistribute bgp 100 metric 1 1 1 1 1
network 10.0.0.0
no auto-summary
autonomous-system 15
exit-address-family
!
router eigrp 15
auto-summary
!
router ospf 101 vrf Cust_site1
log-adjacency-changes
redistribute bgp 100 metric 555 subnets
network 10.1.14.0 0.0.0.255 area 0
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
no auto-summary
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 vrf Cust_site2
redistribute eigrp 15
no synchronization
exit-address-family
!
address-family ipv4 vrf Cust_site1
redistribute ospf 101 vrf Cust_site1
no synchronization
exit-address-family
!
ip forward-protocol nd
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
============================================
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P0R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.12.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip address 10.1.23.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
==================================================
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE0R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip vrf Cust_site1
rd 3.3.3.3:1
route-target export 3.3.3.3:101
route-target import 1.1.1.1:101
!
ip vrf Cust_site2
rd 3.3.3.3:2
route-target export 3.3.3.3:102
route-target import 1.1.1.1:102
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding Cust_site2
ip address 10.1.37.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip vrf forwarding Cust_site1
ip address 10.1.36.3 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip address 10.1.23.3 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router rip
version 2
!
address-family ipv4 vrf Cust_site1
redistribute bgp 100 metric 3
network 10.0.0.0
no auto-summary
exit-address-family
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
no auto-summary
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
neighbor 1.1.1.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf Cust_site2
neighbor 10.1.37.7 remote-as 200
neighbor 10.1.37.7 activate
no synchronization
exit-address-family
!
address-family ipv4 vrf Cust_site1
redistribute rip
no synchronization
exit-address-family
!
ip forward-protocol nd
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
====================================================
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
interface Loopback1
ip address 4.4.4.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.14.4 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 4.4.4.1 0.0.0.0 area 0
network 10.1.14.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
==================================================
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
interface Loopback1
ip address 5.5.5.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.15.5 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router eigrp 15
network 5.0.0.0
network 10.0.0.0
no auto-summary
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
================================================
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
interface Loopback1
ip address 6.6.6.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.36.6 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router rip
version 2
network 6.0.0.0
network 10.0.0.0
no auto-summary
!
ip forward-protocol nd
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
==============================================
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R7
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
interface Loopback1
ip address 7.7.7.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.37.7 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 200
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor 10.1.37.3 remote-as 100
no auto-summary
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
================================================
No comments:
Post a Comment