Lab related to this topic on youtube:
Please find playlist in Hindi & English below:https://www.youtube.com/playlist?list=PL1PiPEQOeKMYqOvyKpym_dkoFY2y5BKt0https://www.youtube.com/playlist?list=PL1PiPEQOeKMY3r659R5gyWt4ScTzpyg6w
INTERNAL BGP PEERING(iBGP)
Topology independent
BGP peer within the same AS
Not required to be direclty connected
iBGP speakers need to be fully meshed they originate connected networks
they do not pass on prefixes learned from other iBGP speakers
EXTERNAL BGP PEERING (eBGP)
Between BGP speakers in different AS
Should be direclty connected
Do not run an IGP between eBGP peers
You can see iBGP relationship and eBGP relationship in the diagram given below.
TWO WAYS TO ADVERTISE BGP NETWORK
A. VIA NETWORK COMMAND
B. VIA REDISTRIBUTION COMMAND
RULES OF BGP
NO SYNC:
DO NOT USE OR ADVERTISE A ROUTE LEARNED VIA iBGP UNTIL THE SAME ROUTE WAS LEARNED FROM
THE INTERNAL ROUTING PROTOCOL.
Lab 2: BGP iBGP & eBGP BGP NETWORK ADVERTISMENT
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.12.1 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 10.1.12.0 0.0.0.3 area 0
!
router bgp 6500
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 6500
neighbor 2.2.2.2 update-source Loopback1
no auto-summary
!
ip forward-protocol nd
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
------------------------------------------------------------------------------------------------------
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.12.2 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.23.1 255.255.255.252
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 10.1.12.0 0.0.0.3 area 0
!
router bgp 6500
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 6500
neighbor 1.1.1.1 update-source Loopback1
neighbor 1.1.1.1 next-hop-self
neighbor 10.1.23.2 remote-as 6501
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
------------------------------------------------------------------------------------------------
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
interface Loopback1
ip address 3.3.3.1 255.255.255.255
!
interface Loopback2
ip address 3.3.3.2 255.255.255.255
!
interface Loopback3
ip address 3.3.3.3 255.255.255.255
!
interface Loopback4
ip address 3.3.3.4 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.23.2 255.255.255.252
clock rate 2000000
!
router bgp 6501
no synchronization
bgp log-neighbor-changes
network 3.3.3.1 mask 255.255.255.255
network 3.3.3.2 mask 255.255.255.255
redistribute connected route-map forbgp
neighbor 10.1.23.1 remote-as 6500
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ip access-list standard adv
permit 3.3.3.3
permit 3.3.3.4
!
!
route-map forbgp permit 10
match ip address adv
!
route-map forbgp permit 1000
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
-----------------------------------------------------------------------------------------------------
No comments:
Post a Comment