Wednesday, 28 December 2016

CCNP ROUTE : ADVANCED REDISTRIBUTION LAB

ON YOUTUBE: https://www.youtube.com/watch?v=vL9-Xf0huNk


CCNP ROUTE : ADVANCED REDISTRIBUTION LAB





!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback2
 ip address 1.1.1.2 255.255.255.255
!
interface Loopback3
 ip address 1.1.1.3 255.255.255.255
!
interface Loopback4
 ip address 1.1.1.4 255.255.255.255
!
interface Loopback5
 ip address 1.1.1.5 255.255.255.255
!
interface Loopback6
 ip address 1.1.1.6 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.12.1 255.255.255.252
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router eigrp 100
 network 1.0.0.0
 network 10.0.0.0
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end
--------------------------------------------------------------------------
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.12.2 255.255.255.252
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.1.24.1 255.255.255.252
 clock rate 2000000
!
interface Serial0/2
 ip address 10.1.23.1 255.255.255.252
 clock rate 2000000
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
router eigrp 100
 redistribute ospf 1 route-map O->E
 network 10.0.0.0
 distance eigrp 90 105
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 100 subnets route-map E->O
 network 10.1.24.0 0.0.0.3 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ip access-list standard eto0
 permit 1.1.1.1
ip access-list standard eto01
 permit 1.1.1.2
ip access-list standard eto02
 permit 1.1.1.3
ip access-list standard otoe
 permit any
!
!
route-map E->O deny 5
 match tag 40
!
route-map E->O permit 10
 match ip address eto0
 set metric 1010
 set tag 10
!
route-map E->O permit 20
 match ip address eto01
 set metric 2020
 set tag 20
!
route-map E->O deny 30
 match ip address eto02
!
route-map E->O permit 1000
 set metric 3030
!
route-map O->E deny 5
 match tag 10 20 30
!
route-map O->E permit 10
 match ip address otoe
 set metric 1 1 1 1 1
 set tag 40
!
route-map O->E permit 1000
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

--------------------------------------------------------------------
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.34.1 255.255.255.252
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.1.23.2 255.255.255.252
 clock rate 2000000
!
router eigrp 100
 redistribute ospf 1 route-map O->E
 network 10.0.0.0
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 100 subnets route-map E->O
 network 10.1.34.0 0.0.0.3 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
route-map E->O deny 5
 match tag 40
!
route-map E->O permit 10
 match ip address eto0
 set metric 1010
 set tag 10
!
route-map E->O permit 20
 match ip address eto01
 set metric 2020
 set tag 20
!
route-map E->O deny 30
 match ip address eto02
!
route-map E->O permit 1000
 set metric 3030
!
route-map O->E deny 5
 match tag 10 20 30
!
route-map O->E permit 10
 match ip address otoe
 set metric 1 1 1 1 1
 set tag 40
!
route-map O->E permit 1000
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

-------------------------------------------------------------------
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!

R4#sh run
Building configuration...

Current configuration : 1077 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
interface Loopback1
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.34.2 255.255.255.252
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.1.24.2 255.255.255.252
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 10.1.24.0 0.0.0.3 area 0
 network 10.1.34.0 0.0.0.3 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

-----------------------------------------------------------------------

No comments:

Post a Comment