ON YOUTUBE:
First a heads up - it's a bit complicated because there are just too many details... Subjective impression!
The command is rather straight forward:
Cisqueros_1(config-router)#eigrp stub connected [connected | summary | static | receive-only | redistributed]
When the EIGRP process is configured as STUB on a router using the "stub connected" command:
Cisqueros_1(config-router)#eigrp stub connected
There are a few things that we need to remember:
Please find playlist in Hindi & English below:https://www.youtube.com/playlist?list=PL1PiPEQOeKMYqOvyKpym_dkoFY2y5BKt0https://www.youtube.com/playlist?list=PL1PiPEQOeKMY3r659R5gyWt4ScTzpyg6w
First a heads up - it's a bit complicated because there are just too many details... Subjective impression!
The command is rather straight forward:
Cisqueros_1(config-router)#eigrp stub connected [connected | summary | static | receive-only | redistributed]
When the EIGRP process is configured as STUB on a router using the "stub connected" command:
Cisqueros_1(config-router)#eigrp stub connected
There are a few things that we need to remember:
- That router will no longer see Connected routes, ONLY the Summary (if configured), and also Static
and Redistributed routes (because the STUB doesn't affect the Router where it's configured)
- The EIGRP Neighbor(s) will NOT see the Summary, Static or Redistributed Routes, ONLY the
specific routes BECAUSE ONLY Connected Routes are advertised
If however we use the "stub summary" command to configure the STUB:
Cisqueros_1(config-router)#eigrp stub stub summary
- The router will keep the same EIGRP routes in the routing table
If however we use the "stub summary" command to configure the STUB:
Cisqueros_1(config-router)#eigrp stub stub summary
- The router will keep the same EIGRP routes in the routing table
- The EIGRP Neighbor(s) will ONLY see the Summary
Now with the "stub static" or "stub redistributed":
Cisqueros_1(config-router)#eigrp stub stub [static | redistributed]
This router keeps behaving exactly the same, while the EIGRP Neigbors ONLY receive the Static OR
Now with the "stub static" or "stub redistributed":
Cisqueros_1(config-router)#eigrp stub stub [static | redistributed]
This router keeps behaving exactly the same, while the EIGRP Neigbors ONLY receive the Static OR
Redistributed routes
With the "stub receive-only":
Cisqueros_1(config-router)#eigrp stub receive-only
This router keeps behaving exactly the same, while the EIGRP Neigbors stop receiving ANY routes
With the "stub receive-only":
Cisqueros_1(config-router)#eigrp stub receive-only
This router keeps behaving exactly the same, while the EIGRP Neigbors stop receiving ANY routes
from the Router
And finally the "eigrp stub" command can be configured without any attributes, so just:
Cisqueros_1(config-router)#eigrp stub
in which case the EIGRP neighbors ONLY receive the Summary Route
And finally the "eigrp stub" command can be configured without any attributes, so just:
Cisqueros_1(config-router)#eigrp stub
in which case the EIGRP neighbors ONLY receive the Summary Route
EIGRP LAB TWO: STUB & NETWORK TYPE , WITH BANDWIDTH UTILIZATION:
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
!
interface Serial0/0.1 multipoint
ip address 10.1.1.1 255.255.255.0
ip bandwidth-percent eigrp 100 80
no ip split-horizon eigrp 100
frame-relay map ip 10.1.1.2 102 broadcast
frame-relay map ip 10.1.1.3 103 broadcast
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router eigrp 100
network 1.0.0.0
network 10.0.0.0
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
end
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
!
interface Serial0/0.1 multipoint
ip address 10.1.1.2 255.255.255.0
ip bandwidth-percent eigrp 100 80
no ip split-horizon eigrp 100
frame-relay map ip 10.1.1.1 201 broadcast
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router eigrp 100
network 2.0.0.0
network 10.0.0.0
no auto-summary
eigrp stub connected summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
end
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.3 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 10.1.1.1 301 broadcast
!
interface Serial0/0.1 multipoint
ip bandwidth-percent eigrp 100 80
no ip split-horizon eigrp 100
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router eigrp 100
network 3.0.0.0
network 10.0.0.0
no auto-summary
eigrp stub connected summary
!
ip forward-protocol nd
!
end
No comments:
Post a Comment