LAB WORK:
configuration of all the devices:
=========================================================
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.10 255.255.255.0
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
ip default-gateway 192.168.1.1
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
===================================================
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
class-map match-any MAF22
match dscp af22
class-map match-any MAF33
match dscp af33
!
!
policy-map P_LLQ
class MAF22
bandwidth percent 10
class MAF33
priority percent 90
class class-default
fair-queue
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nbar protocol-discovery
duplex auto
speed auto
max-reserved-bandwidth 100
service-policy output P_LLQ
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay interface-dlci 102
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router eigrp 100
network 10.0.0.0
network 192.168.1.0
auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
alias exec NPT sh ip nbar protocol-discovery stats bit-rate top-n 5
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
=============================================================
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
class-map match-any TT
match protocol telnet
class-map match-any HT
match protocol http
!
!
policy-map POL_TRA
class HT
set dscp af33
class TT
set dscp af22
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.2 255.255.255.0
ip nbar protocol-discovery
encapsulation frame-relay
clock rate 2000000
frame-relay interface-dlci 201
service-policy output POL_TRA
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router eigrp 100
network 10.0.0.0
network 192.168.2.0
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
alias exec NPT sh ip nbar protocol-discovery stats bit-rate top-n 5
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
==================================================================
!
hostname R4
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip cef
!
!
!
!
!
username ratnesh privilege 15 password 0 ratnesh
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.2.10 255.255.255.0
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
ip default-gateway 192.168.2.1
ip forward-protocol nd
!
!
ip http server
ip http authentication local
no ip http secure-server
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
password cisco
login
!
!
end
=====================================================================
configuration of all the devices:
=========================================================
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.10 255.255.255.0
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
ip default-gateway 192.168.1.1
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
===================================================
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
class-map match-any MAF22
match dscp af22
class-map match-any MAF33
match dscp af33
!
!
policy-map P_LLQ
class MAF22
bandwidth percent 10
class MAF33
priority percent 90
class class-default
fair-queue
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nbar protocol-discovery
duplex auto
speed auto
max-reserved-bandwidth 100
service-policy output P_LLQ
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay interface-dlci 102
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router eigrp 100
network 10.0.0.0
network 192.168.1.0
auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
alias exec NPT sh ip nbar protocol-discovery stats bit-rate top-n 5
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
=============================================================
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
class-map match-any TT
match protocol telnet
class-map match-any HT
match protocol http
!
!
policy-map POL_TRA
class HT
set dscp af33
class TT
set dscp af22
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.2 255.255.255.0
ip nbar protocol-discovery
encapsulation frame-relay
clock rate 2000000
frame-relay interface-dlci 201
service-policy output POL_TRA
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router eigrp 100
network 10.0.0.0
network 192.168.2.0
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
alias exec NPT sh ip nbar protocol-discovery stats bit-rate top-n 5
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
==================================================================
!
hostname R4
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip cef
!
!
!
!
!
username ratnesh privilege 15 password 0 ratnesh
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.2.10 255.255.255.0
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
ip default-gateway 192.168.2.1
ip forward-protocol nd
!
!
ip http server
ip http authentication local
no ip http secure-server
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
password cisco
login
!
!
end
=====================================================================
No comments:
Post a Comment