Wednesday, 28 December 2016

IPv6 ROUTING PROTOCOLS LAB : OSPF & RIP REDISTRIBUTION

YOUTUBE LINK:

Please find playlist in Hindi & English below:https://www.youtube.com/playlist?list=PL1PiPEQOeKMYqOvyKpym_dkoFY2y5BKt0https://www.youtube.com/playlist?list=PL1PiPEQOeKMY3r659R5gyWt4ScTzpyg6w

Sometimes to write every thing is very difficult so you please watch the videos associated with this page.



                                     OSPFv3

Similar in operation to ospfv2
router-id is ipv4 address
-use "router-id"command if no IPv4 configured
configuration
-interface level "ipv6 ospf[process-id] area
-automatically enables global process

                                OSPFv3 OVER NBMA

same network types as ospfv2
-Broadcast                                  DR/BDR election
-Non-Broadcast                          DR/BDR election
-Point-to-Point
-Point-to-multipoint
-Point-to-multipoint non-broadcast
unicast updates to link-local address


                   OSPFv3 & RIP REDISTRIBUTION LAB



R1#sh run
Building configuration...

Current configuration : 1011 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 ipv6 address 12::1/64
 ipv6 ospf 1 area 10
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

R1#
R1#sh ipv route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C   12::/64 [0/0]
     via ::, Serial0/0
L   12::1/128 [0/0]
     via ::, Serial0/0
OI  23::/64 [110/128]
     via FE80::C201:4FF:FE34:0, Serial0/0
OE2  34::/64 [110/33]
     via FE80::C201:4FF:FE34:0, Serial0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

--------------------------------------------------------------------------------------------------
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 ipv6 address 12::2/64
 ipv6 ospf 1 area 10
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 ipv6 address 23::2/64
 ipv6 ospf 1 area 0
 clock rate 2000000
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end
------------------------------------------------------------------------------
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 ipv6 address 34::3/64
 ipv6 rip 1 enable
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 ipv6 address 23::3/64
 ipv6 ospf 1 area 0
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 redistribute rip 1 metric 33 include-connected
!
ipv6 router rip 1
 redistribute ospf 1 metric 4
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

----------------------------------------------------------------------------------
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 ipv6 address 34::4/64
 ipv6 rip 1 enable
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 router rip 1
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

R4(config-if)#  do sh ipv route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
R   12::/64 [120/5]
     via FE80::C202:4FF:FE34:0, Serial0/0
C   34::/64 [0/0]
     via ::, Serial0/0
L   34::4/128 [0/0]
     via ::, Serial0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0
--------------------------------------------------------------------------------------

No comments:

Post a Comment